User Tools

Site Tools


public:t-vien-10-3:blendertexturing

Blender Model Export and UV Texturing

  • Here are the steps required for exporting a textured object from Blender3D to Panda3D (NOTE: You have to use Blender versions BEFORE 2.5, because the Panda exporter doesn't yet work in 2.5 or later). If you have access to MySchool, you can view these steps in action in the video that has been uploaded into the course there under “Demos”.
    1. Configure your Blender 3D environment by “dragging down” the top menu bar to reveal configuration options. You may want to change “Selection” to “Left Mouse Button” and rotation to “Turntable”
    2. Select the cube (Left mouse button if you have changed the configuration, Right otherwise)
    3. Name the selected object “Box” (press “n” for the “name” box)
    4. Switch to Edit Mode (The mode selector currently shows “Object Mode”)
    5. Switch to Edge Select Mode (Three buttons on the bottom bar of the window: vertex, edges and polys)
    6. Multi-select the “seam” Edges of the Box (for a fold-out cube)
    7. Mesh→Edges→Mark Seam
    8. View→Front
    9. View→Orthographic
    10. Split main window (RMB on bottom line of window→Split)
    11. Select “UV/Image” view for new window
    12. Select your object again in the 3D view (press “a” to select the whole object)
    13. 3D Window: Mesh→UV Unwrap→Unwrap (you should now see the fold-out texture from the cube appear in the right UV/Image window)
    14. UV Window: UVs→Scripts→Save UV Face Layout..
  • And now you have a texture which you can edit in your favourite paint program (like GIMP, which is free!). Once you're done painting it, you can import it back into Blender like this:
  • UV Window: Image→Open (pick your file here and it is applied to your object)
  • To see it in the 3D Window, choose “Draw Type: Textured” from the Draw Type pop-up menu next to “Edit Mode”
  • Exporting the object to Panda3D requires that you have the "Chicken Exporter Plug-In". If it is properly installed, simply choose “Chicken” from the File→Export menu.
  • You can now load the model like any other model with loader.loadModel(“Box.egg”)
/var/www/ailab/WWW/wiki/data/pages/public/t-vien-10-3/blendertexturing.txt · Last modified: 2011/05/04 21:10 by hannes